Patch for Critical Vulnerability in Magento